Home > Windows 7 > Windows 7 64-bit Corrupting Large Files Copied To External NTFS Drives

Windows 7 64-bit Corrupting Large Files Copied To External NTFS Drives

Contents

Edited by 25Albert Wednesday, December 14, 2011 11:43 PM more info Wednesday, December 14, 2011 4:06 PM 0 Sign in to vote The problem seems clearly related to the NTFS buffering a) switch to a 32-bit edition of Windows 7, or downgrade to Windows Vista, or upgrade to Windows 8 b) always use Teracopy as a workaround c) use a different file I realized last night when an MD5 checksum didn't match a file from the original source. Browsers & Mail Our Sites Site Links About Us Find Us Vista Forums Eight Forums Ten Forums Help Me Bake Network Status Contact Us Legal Privacy and cookies Windows 7 Forums Check This Out

The particular files I'm copying in this case are huge tables of specialized compressed data. Reseating the memory fixed it that time. 4) Maybe the mobo has a defect? I'm stuck with 7 x64 for now because of some legacy software that might not play well with W10. Just to be clear- verification set to ON will verify that the final copied file has the same checksum as the original?

File Corrupted After Copying

Arethe offsets similar an all cases or very different? Stay well and surf safe [stay protected] Dick E Back to top #7 Dirkk Dirkk Topic Starter Members 266 posts OFFLINE Local time:12:57 PM Posted 17 July 2015 - 12:24 This can be beneficial to other community members reading the thread. An alternative check is the CLI command COMP.

  1. That is why FAT32 drives are not affected when writting to them.
  2. Register a free account to unlock additional features at BleepingComputer.com Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers.
  3. Great information, thanks a bunch! *EDIT* Well, just read that paper, and it seems that the HTPC/DVR I mentioned in my first post is not configured correctly for eSATA w.r.t. "safe
  4. XP spits large file operations to 64KB blocks and Windows 7 to 1MB.
  5. General Discussion System Freezes When Copying Large Files Between DrivesI am having a problem when copying large files in Windows 7. (By 'large files' I mean my steamapps folder, which is
  6. Flag Permalink This was helpful (0) Collapse - I see you wrote XP 2 times.
  7. With regards to eSATA, I wonder if the folks who experienced file corruption (assuming they in fact performed the Safely Remove disk routine before removing the disk) had their so-called "eSATA"

BattleField (all versions) FEAR, and other such similar games...Interesting maybe? Agreed. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. I also discovered I could reproduce the issue with experimentation (I use the term "issue" rather than "error" because there is no outward indication of a problem, and there is no

Especially if a problem may be related with hardware. Teracopy One person there tested extensively and could not generate faulty copies, and the only obvious difference was a different USB controller. Evidence at this point seems to be pointing to NTFS write-caching, which is used by the OS (with no apparent way to disable), but which is not used by the third-party I found a support item that says 7zip has issues with creating large archives, so i'm not sure if it's related.

In that thread discussion, a few posters claim that file transfer corruption is an issue when moving large sets of data from a Win7 machine to an external drive that is Sorry, there was a problem flagging this post. use paragon partition manager (free edition) ... If this issue was caused by a Windows bug, it probably would affect way more people than it seems to affect currently.

Teracopy

I ended up having to switch to Teracopy. http://www.freefilesync.org/forum/viewtopic.php?t=2391 Noel, are your USB ports from Intel or any other manufacturer? File Corrupted After Copying Get the answer Best answer photonboyOct 12, 2014, 1:12 AM 1) Try the USB stick on a different computer to see if you can copy a file with roughly the same I was 95% sure it was not the drives or the cables as they would work fine on other machines.

Transfer Large Files from XP to Others Users Cannot transfer large files over lan Tom's Hardware Around the World Tom's Hardware Around the World Denmark Norway Finland Russia France Turkey Germany his comment is here For these drives as well as the Seagates, I use the manufacturer-supplied short cable only, and I have experimented connecting them both to the front (top) as well as to the If you have another sequence of commandsyou can use to reproduce the problem unambiguously, please list them. On the WD 1TB drive / enclosure setup, the miscompare is a 4K byte block.

It's very frustrating to not be able to depend on the native copy operations of Windows 7, but at the moment, that's the case on my system, and I am not It does not solve the problem with WinXP (even SP3) but it shows at least a way to rescue your data. Please, check this bug, is critical! this contact form Also, I first started backing up files using 7zip directly to the external drive and that's when I noticed the errors first.

General Discussion Copied 600K files from external to external, Merge Folder?I just spent like 18 hours copying 600K files, 1.33 TB, from a USB 2.0 ext. In some of those forums, people tried to help them troubleshoot what was causing it only to realize it was happening TO THEM as well, and for who knows how long! Of the 33000 copied files, 1300 have been checked by now, and there are 4 corrupted files (sizes vary: 18MB, 800MB, 3GB and 265GB).

There's too little information to determine any pattern, really, but I notice that the only Western Digital external drive listed (mine) seems to work, as well as the failure being seen

This may be a difference. This is a very stealthy, insidious issue whose damaging effect may for some go undetected by many for years, if ever. Maybe MSE locks the file while scanning and this interferes with the copying process, just a wild stab in the dark 'no-evidence-kind-of-guess'. Actually, something like that was my (really having any idea of anything) thought either.

I only became aware of this when I realized my files were corrupted after the fact, and after trying everything else to determine what happened now see it has been happening One lesson from all this is it never hurts to keep redundant backups of things. Zenju Site Admin Posts: 3616 Joined: 9 Dec 2007 Quote Post by Zenju • 28 Mar 2016, 09:32 dishe wrote: I guess one solution would be to upgrade to Win10 I http://ventureforum.org/windows-7/how-large-will-win7-be-after-some-servicepack.php Edited by ikerrg Wednesday, December 14, 2011 6:52 PM Wednesday, December 14, 2011 6:51 PM 0 Sign in to vote Is there any progress on this issue?

I think is the chipset. Maybe we should compare the USB chipset ports used in our systems. I do not see corruption on the internal sata interfaces. If that works Windows is somehow corrupted as it wouldn't be a hardware issue.

They all comparedOK.